Jump to content

Photo

High Blood sugar and it wont go down!

- - - - -

  • Please log in to reply
4 replies to this topic

#1
Spbeyond

Spbeyond

    Member

  • 500 plus
  • 230 posts
Hey everyone. Last few days I have had high blood sugar. its like mid 300s-450. And even after applying liberal insulin they dont seem to be going down. Any suggestions? THanks
When I have diabetes, I just stop having diabetes and be awesome instead!

#2
davef

davef

    Senior Member

  • 500 plus
  • 8,081 posts
Hi,

I can't remember if you are using MDI or Pump. And bear in mind I'm a T2 not using insulin. If you are on MDI, is your insulin expired/off? If pump, is there a problem with the set?

Other than the high BG, are you well? Have you a cold, flu, stomach bug? Are you experiencing stress at the moment? - While thos things can raise your BG, bringing them up to 300-450 does seem a big increase (depending on your normal levels).

I think that after a few days running that high it it time to see a Doctor. Have you checked for ketones?
Posted Image

By Endurance, we conquer - Shackleton Family Motto
Insulin resistance is futile - I will win - me

Metformin 3000mg daily, Enap 5mg, Victoza 1.8mg, Lantus (currently 14u)
Diagnosed T2 on 26th Nov'07, with FBG of 21mmol/L (378mg/dL) and A1c of 11.6%.
Most recent A1c 20/11/13: 11.6% <= back where I started

#3
SueM

SueM

    Senior Member

  • 500 plus
  • 1,399 posts
Have you changed your insulin vial/cartridge to rule out insulin problems? If on MDI change both bolus and basal if you haven't done so.
If using a pen are you sure no air bubbles preventing insulin delivery? Is the pen working properly?
Sue
Pumping using bovine insulin. (Pump kindly donated by Solox)

#4
kgm0612

kgm0612

    Senior Member

  • 500 plus
  • 7,672 posts
Another question.........how's your diet been? Have you been eating foods that you normally wouldn't be eating?

For myself.......when my numbers start to run high, I know it's either the insulin or the site. I usually change the site out first and if that doesn't work, I open a new vial of insulin.

Good Luck!

Karen

#5
bgbinc

bgbinc

    Junior Member

  • Members
  • PipPip
  • 14 posts

Hey everyone. Last few days I have had high blood sugar. its like mid 300s-450. And even after applying liberal insulin they dont seem to be going down. Any suggestions? THanks


I'd suggest changing everything: insulin, sets/reservoirs/tubing if using a pump. Also, if using a pump, you might try going MDI for a day to see if you have pump step motor/controller issue. Another thing to check is the lot/code number on your strips to ensure that you are getting the correct reading out of the glucometer. If you have a 2nd glucometer, I'd try that as well. Good luck!! :creep:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users